Función BUSCARV y CONTAR.SI en Excel

October 20th, 2010 | by admin |

Recientemente nos hemos visto en la necesidad de contrastar cierta información que nos viene en Excel, y como no, hemos buscado la forma de hacerlo de una forma automática. En este caso tenemos una tarifa en formato Excel que nos envían periódicamente y debemos comprobar si los precios de los artículos han variado ya que hemos de actualizar nuestros precios de venta. Al final todo lo hemos resuelto solo con dos formulas.

BUSCARV

Función que busca la coincidencia del parámetro 1 (L10) en el rango del parámetro 2 ($C$6:$E$10)
y devuelve el valor de la columna parámetro 3 a la derecha del inicio del rango (3). El false le indica que los matriz no esta ordenada.

=BUSCARV(L10;$C$6:$E$10;3;FALSO)

 

CONTAR.SI

Esta función la hemos implementado para comprobar que la referencia que nos mandan no esta repetida (en algunos caso esto es así y la función BUSCARV solo nos devuelve el primer valor. La función cuenta en el rango del parámetro 1 (C7:C100) el valor del parámetro 2 (L8) y cada vez que lo encuentra suma 1 mostrando el total de coincidencias.

=CONTAR.SI($C$7:$C$100;L8)

admin (133 Posts)


Post a Comment